
Adobe Dreamweaver CS6 Project 2 guide
How to make websites accessible
Creating accessible web pages has never been more important than today. With the adoption of accessibility standards 
in the United States, Canada, the European Union, Australia, Japan, and other countries, designers and developers 
need to ensure that people with disabilities can access the contents of websites and web applications, as well as the 
authoring tools used to create them.

Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and other 
disabilities. Examples of accessibility features for software products and websites include screen reader support, text 
equivalents for graphics, keyboard shortcuts, change of display colors to high contrast, and so on. Dreamweaver 
provides tools that make it accessible to use and tools that help you author accessible content.

Dreamweaver enables designers and developers to create accessible pages that contain useful content for screen 
readers and comply with federal government guidelines. For example, dialog boxes prompt you to enter accessibility 
attributes—such as text equivalents for an image—when you insert page elements. Then, when the image appears on 
a page for a user with visual disabilities, the screen reader voices the description.

Note: For more information about two significant accessibility initiatives, see the World Wide Web Consortium Web 
Accessibility Initiative (www.w3.org/wai) and Section 508 of the U.S. Federal Rehabilitation Act 
(www.section508.gov). 

No authoring tool can automate the development process. Designing accessible websites requires you to understand 
accessibility requirements and make ongoing decisions about how users with disabilities interact with web pages. The 
best way to ensure that a website is accessible is through deliberate planning, development, testing, and evaluation.

Accessibility preferences options
To create accessible web pages, page elements need to be marked up with information for assistive technology, such 
as screen readers. For example, each image on a page should be given a text equivalent, called alternative text (alt 
text), that a screen reader voices to users in place of the image (Figure 1).

Figure 1 Displaying alternative text

Designers often overlook accessibility features such as alt text when creating websites, but Dreamweaver CS6 
enables you to set preferences that prompt you to provide accessibility information as you’re building the page. By 
activating options in the Preferences dialog box, you'll be prompted to provide accessibility-related information for 
form objects, frames, media, images, and tables as each element is inserted in a page. 
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To set the accessibility preference, choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS) 
and select the Accessibility category in the Preferences dialog box (Figure 2).

Figure 2 Dreamweaver Preferences dialog box, Accessibility category

For example, if you choose the Images option in the Show Attributes list, you are prompted (Figure 3) to provide the 
alt text equivalent and a description for each image as you insert it.

Figure 3 Image Tag Accessibility Attributes dialog box
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Creating accessible tables and forms presents some challenges, but Dreamweaver CS6 simplifies the process. For 
example, as you insert a data table within Dreamweaver CS6, you're immediately prompted to provide summary 
information, a caption, and the position of heading cells in the table (Figure 4). Incidentally, by adding identifying 
heading cells—an important but often overlooked design step—you make it significantly easier for assistive 
technology users to navigate tables. 

Figure 4 Table dialog box

Creating accessible forms is also easy with Dreamweaver CS6. When you select the Form Objects option in the 
Preferences dialog box, you're prompted to provide a label for each form object, along with a shortcut key and the tab 
order position (Figure 5). Specifying the label allows assistive technology users to understand the purpose of each 
form object as they complete the form.

Figure 5 Input Tag Accessibility Attributes dialog box
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Accessibility validation
There are a number of third-party web accessibility evaluation tools that you can use to validate your completed 
websites. The W3C Web Accessibility initiative provides a comprehensive list of these tools at http://www.w3.org/
WAI/RC/tools/.

Accessible templates
Dreamweaver CS6 includes several templates designed for accessibility. These templates are visually balanced, as 
well as accessible to people with disabilities (Figure 6). They provide you with a fast and easy way to create exciting, 
engaging, and accessible content. 

Figure 6 Dreamweaver sample HTML template

How to meet accessibility requirements
The W3C Web Accessibility Initiative has developed a quick reference list Web Content Accessibility Guidelines 2.0 
requirements and techniques.

1. Text Alternatives: Provide text alternatives for any non-text content so that it can be changed into other 
forms people need, such as large print, braille, speech, symbols or simpler language.

2. Time-based Media: Provide alternatives for time-based media.

3. Adaptable: Create content that can be presented in different ways (for example simpler layout) without 
losing information or structure.

4. Distinguishable: Make it easier for users to see and hear content including separating foreground from 
background.

5. Keyboard Accessible: Make all functionality available from a keyboard.
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6. Enough Time: Provide users enough time to read and use content.

7. Seizures: Do not design content in a way that is known to cause seizures.

8. Navigable: Provide ways to help users navigate, find content, and determine where they are.

9. Readable: Make text content readable and understandable.

10. Predictable: Make Web pages appear and operate in predictable ways.

11. Input Assistance: Help users avoid and correct mistakes.

12. Compatible: Maximize compatibility with current and future user agents, including assistive technologies.
© 2012 Adobe Systems Incorporated How to make websites accessible 5



Adobe Dreamweaver CS6 Project 3 guide
How to add rich media to a web page
To add interest and interactivity, you can easily add rich media to web pages. Rich media includes most kinds of 
video, Flash videos, audio files, and interactive Flash content. 

When building web pages that will be viewed across different devices and screen sizes, consider using HTML5. 
HTML5 video is emerging to become the new standard way to show video on the web. Dreamweaver supports the 
HTML5 <video> tag that allow users to play video files in a browser, without an external plug-in or player 
(Figure 1). 

Figure 1 Viewing HTML5 video in a browser

HTML5 video
There are a few steps you need to accomplish before setting up your web page for HTML5 rich media.

• Create a video in H264 format. You can use the Adobe Media Encoder CS6 or the website www.online-
convert.com to convert video into a range of formats. If you want viewers to be able to play your video in a 
Firefox browser, you should also create a WebM or Flash (FLV) version of your video. 

• Create a poster image that is the same size and orientation as the video. This graphic provides a splash 
screen for viewers to see while the video is downloading. If no poster is specified, a browser will display the 
first frame of the video.

• Include a folder named video in your site, and place the video file and poster image in it.

Once a video is embedded in a page, you can use Live view in the Document window to render and preview rich 
media.

Note: Although you can embed rich media in your web page, Live view does not always render all videos. The audio 
and video tags are supported in Dreamweaver by using the Apple QuickTime plug-in. In Windows, if the Apple 
QuickTime plug-in is not installed, then the web page does not render the media content.
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To create the HTML5 page and video:

1. Start Dreamweaver.

2. Select File > New. 

The New Document dialog box opens (Figure 2).

3. Click the Blank Page category link if not already open, 
and select HTML from the Page Type column, and 
<none> from the Layout column.

4. Select the HTML5 document type from the DocType 
pop-up menu.

5. Click the Create button.

6. Save the new document (File > Save).

The Save As dialog box opens.

7. Navigate to your Dreamweaver site folder, name the file, 
and click Save.

8. Click the Split button in the Document toolbar at the top 
of the document window (Figure 3).

Code view and Design view are visible in the document 
window.

You work in Code view in the next steps as you set up the 
video player with the specifications for your own video 
files. 

9. In Code view, locate the <body> tag, and place the 
insertion point at the end of the the opening body tag.

10. Press Enter (Windows) or Return (Mac OS) to create a 
new line for code.

11. Type <vi and then press Tab to complete the beginning of 
the <video tag.

12. Press the spacebar and type src and then press Tab to 
complete the the source parameter.

The Browse link appears (Figure 4).

13. Click the Browse link to open the Select File dialog box.

14. Navigate to the H.264 video file you saved to the video 
folder and double-click that file to select it.

15. Press the spacebar and then double-click Controls from 
the list of code hints (Figure 5).

This adds a parameter to tell the browser to display 
playback controls with the video.

16. Press the spacebar and type po and then press Tab to 
complete the the poster parameter.

The Browse link appears.

Figure 2 New Document dialog box

Figure 3 Document toolbar

Figure 4 Code hints

Figure 5 Code hints

DocType pop-up menu
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17. Click the Browse link to open the Select File dialog box.

18. Navigate to the poster file you saved to the video folder and double-click that file to select it.

19. Press the spacebar and type prel and then press Tab to complete the the preload parameter.

20. Select Auto from the list of available options. 

The preload parameter tells the browser to load the entire video when the page loads.

Figure 6 Sample code

21. Place the insertion point after the closing preload quote.

22. Press the spacebar and then type ></.  

Dreamweaver will complete the closing tag </video>.

23. Place the insertion point before the closing tag </video>.

24. Press Enter (Windows) or Return (Mac OS) twice to create a blank line for code.

25. Enter (or copy and paste) the following code just before the closing video tag:

<p>Your browser does not support HTML5 video. Click here to download it.</p>

You’ve added text that will display in browsers that don't support HTML5, but you need to add a link to the file 
so users can download it.

26. In Code view, highlight the sentence Click Here To Download It.

27. Click in the Design window to update the preview.

28. Drag the Point-To-File icon  (target icon) at the right of the Link box in the Property inspector and point to the 
video in the Files panel.

A link is created to the video file as in Figure 7.

Figure 7 Sample code

29. Save the file (File > Save).
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30. Select File > Preview In Browser, and select a browser to 
preview the video in a web browser (Figure 8).

Figure 8 Test movie in browser

Troubleshooting support for Firefox

To this point, you’ve embedded a video file in a web page using the HTML5 Video element (tag), and added a link 
that displays a message if a viewer tries to watch the video in a browser that doesn't support HTML5. This approach 
works well across versions of current browsers including Chrome, Safari, and Internet Explorer.  Unfortunately, the 
video won't play in Firefox because it does not support H.264 video. Because Firefox does support HTML5, the text 
link to open the video in a new browser window also won't display. This problem is typical of the kind of issues you'll 
encounter with HTML5 video: it’s still a work in progress. 

You can check with the W3C for the latest information about browser support for HTML5 video at www.w3.org/
wiki/HTML/Elements/video.

To add support for a Firefox browser:

1. Add a simple message after the closing video tag:

<p>Firefox viewers click here to watch the 
video.</p>

2. Create a link to a version of the video in one of the 
formats that Firefox supports, such as WebM or Flash 
Video (FLV).
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About FLA, SWF, and FLV file types
Before you use Dreamweaver to insert content created with Adobe Flash, you should be familiar with the following 
file types:

FLA file (.fla) the source file for any project, created in Flash. This file type can be opened only in Flash (not in 
Dreamweaver or in browsers). In Flash, you can publish a FLA file as a SWF file to use in browsers.

SWF file (.swf) a compiled version of the FLA (.fla) file, optimized for viewing on the web. This file can be 
played back in browsers and previewed in Dreamweaver, but cannot be edited in Flash. 

FLV file (.flv) a video file that contains encoded audio and video data that can be played in Flash® Player. If you 
have a QuickTime or Windows Media video file, use an encoder such as Flash® Video Encoder or Sorensen 
Squeeze to convert the video file to an FLV file. 

Adding FLV video to a web page

You can easily add FLV video to your web pages without using the Flash authoring tool. You must have an encoded 
FLV file before you begin.  Dreamweaver inserts a SWF component that displays the FLV file; when viewed in a 
browser, this component displays the selected FLV file, as well as a set of playback controls. You can also use Live 
view to provide a non-editable, more realistic rendering of how the page will appear in a browser. Live view does not 
replace the Preview In Browser command, but provides another way of seeing what your page looks like “live,” 
without having to leave the Dreamweaver workspace.

To add an FLV video to a web page:

1. Start Dreamweaver and open the document in which you 
want to insert the FLV video.

2. Place the insertion point in Design view where you want 
to add the FLV video.

3. Select Insert > Media > FLV.

The Insert FLV dialog box opens (Figure 9).

4. Click the Browse button to the right of the URL text box.

5. Locate and select the Flash video (FLV), and then click 
OK (Windows) or Open (Mac OS).

6. In the Insert FLV dialog box, select Progressive 
Download Video from the Video Type pop-up menu. 

The Progressive Download Video option enables visitors 
to see movies as they download instead of waiting until 
the entire movie has downloaded.

Note: The Streaming Video option requires the use of 
Adobe Flash Media Server.

7. Fill in the Width and Height boxes.

Dreamweaver requires this information to include the 
video.

8. Select a skin from the Skin pop-up menu.

This determines the appearance of the Flash video 
playback controls (Figure 10).

Figure 9 Insert FLV dialog box

Figure 10 Flash video in a browser with Clear Skin  
selected
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9. Select the Auto Play option to cause the video to play 
when the page loads.

10. Select the Auto Rewind option to cause the video to 
rewind automatically when it reaches the end.

11. Click OK to close the dialog box and insert the video.

A Flash Video placeholder appears in your document 
(Figure 11).

Note: If the Copy Dependent Files dialog box opens, 
click OK to copy the necessary scripts to your site for 
proper playback of the video.

12. Save the document. 

13. In Design view, click the Live View button in the 
Document toolbar.

Figure 11 Flash Video placeholder

Adding  Flash movies (SWF files) to a web page

You add a Flash movie just as you would an image, by browsing to and selecting the Flash file. The file extension of 
Flash movies is SWF.

To add a SWF file to a web page:

1. Start Adobe Dreamweaver and open the document in 
which you want to insert the Flash movie.

2. Place the insertion point in Design view where you want 
to add the Flash movie.

3. Select the Common category in the Insert panel.

4. Click the down arrow on the Media button and select 
SWF in the pop-up menu (Figure 12).

The Select SWF dialog box opens (Figure 13).

Figure 12 Media pop-up menu

Figure 13 Select SWF dialog box
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5. Locate and select the Flash movie (SWF), and then click 
OK (Windows) or Open (Mac OS).

The Object Tag Accessibility Attributes dialog box opens 
(Figure 14).

6. In the Title text box, type a brief title to identify the 
movie’s contents. Then click OK.

A Flash content placeholder, rather than a scene from the 
Flash movie itself, appears in your document 
(Figure 15). This is because the page is pointing to the 
Flash SWF file. When a visitor opens this page, the 
browser plays the SWF file.

To determine how the movie plays when the page loads, 
you set options in the Properties panel.

7. Make sure the Flash content placeholder is selected.

8. In the Properties panel (Figure 15), select the Loop 
option to cause the movie to repeat as long as the visitor 
is on the page. Or, if you don’t want the movie to loop, 
make sure that the Loop option is not checked.

9. Select the Autoplay option to cause the movie to play 
when the page loads.

10. To test the movie, click Play.

Dreamweaver plays the Flash file in the document, 
showing you what visitors will see when they view the 
page in a browser.

11. When you are finished viewing the Flash movie, click 
Stop in the Properties panel.

Figure 14 Object Tag  Accessibility Attributes 
dialog box

Figure 15 Flash movie placeholder in the Document window and Properties panel
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Editing a SWF file from Dreamweaver in Flash

If you have both Flash and Dreamweaver installed, you can select a SWF file in a Dreamweaver document and use 
Flash to edit it. Flash does not edit the SWF file directly; it edits the source document (FLA file) and re-exports the 
SWF file.

To edit a SWF file from Dreamweaver:

1. In Dreamweaver, open the Properties panel (Window > 
Properties).

2. In Design view, click the SWF file placeholder to select 
it; then in the Properties panel, click Edit.

3. In Flash, browse to locate and then select the FLA file. 
Edit the FLA file as you choose.

The Flash edit bar indicates that you are modifying the 
file from within Dreamweaver (Figure 16).

4. When you finish making edits, click Done in the Flash 
edit bar (in the upper-left corner of the workspace). 

Flash updates the FLA file and re-exports it as a SWF 
file.

5. Return to Dreamweaver.

6. To view the updated file in the document, click Play in 
the Properties panel (Figure 17) or press F12 to preview 
your page in a browser window.

Figure 16 Flash edit bar

Figure 17 Flash movie, Play mode, in the Dreamweaver Document window
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Adding audio to a web page
You can add sound to a web page. There are several different types of sound files and formats, including .wav, .midi,  
.mp3, and .ogg . Some factors to consider before deciding on a format and method for adding sound are its purpose, 
your audience, file size, sound quality, and differences in devices and web browsers. 

There are two methods for adding audio to a web page: Use a plug-in or encode your page using HTML5.

When using a plug-in, remember that sound files can be handled differently and inconsistently by different browsers. 
For more information about common audio file formats along with some of the advantages and disadvantages of each 
for web design, see Dreamweaver Help, Audio File Formats.

HTML5 provides additional flexibility for adding audio files to web pages without a plug-in. However, devices and 
web browsers must support the new standard for the audio to work properly. You use the <audio> element to embed 
an audio file on a web page. As with HTML5 video files, be sure to convert your audio files into three supported 
formats: .ogg, mp3, and .wav. These sources are listed in the <audio> tag, and the browser will use the first 
recognized format.

Note: When incorporating sound files in your web pages, carefully consider their appropriate use in your web site 
and how visitors to your site use these media resources. Always provide a control to either enable or disable the 
playing of the sound, in the event that visitors don’t want to listen to the audio content.

To add an audio file by using a plug-in:

1. Start Dreamweaver and open the document in which you want to add sound.

2. In Design view, place the insertion point where you want to embed the file and select Insert > Media > Plugin.

3. Browse for the audio file and click OK (Windows) or Open (Mac OS).

4. Enter a width and height in the W and H text boxes in the Properties panel or by resizing the plug-in placeholder 
in the Document window (Figure 18).

These values determine the size at which the audio controls are displayed in the browser. Audio controls have no 
fixed dimension so find a size that is suitable for the web page in which it is used. For the example in Figure 18, 
the size is set to 257 W x 128 H. 

5. Save the file.

6. Select File > Preview In Browser, and then select a browser to preview the audio in a web browser.

Figure 18 Audio plug-in placeholder in the Document window and Properties panel
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To add an audio file by using HTML5:

1. Create a new HTML5 document, or open an existing HTML5 document in which you want to add audio.

2. Click the Split button in the Document toolbar at the top of the document window.

3. In Code view, enter (or copy and paste) the following code between the <body> tags, substituting your folder 
and filename paths for the placeholders in the code:
<audio controls>

  <source src="folder/song-title.ogg" type="audio/ogg" />

  <source src="folder/song-title.mp3" type="audio/mpeg" />

  <source src="folder/song-title.wav" type="audio/wav" /> 

   <p>Your browser does not support the audio element.</p>

</audio> 

The control attribute adds audio controls, like play, pause, and volume. The text at the end of the <audio> tag is 
for browsers that do not support the element.

The folder and filename paths for the sample site are shown in Figure 19. 

Figure 19 Sample code

4. Save the document. 

5. Select File > Preview In Browser, and then select a browser to preview the audio in a web browser (Figure 20).

Figure 20 Test audio in browser
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How to check links
Use the Check Links feature to search for broken links and orphaned files (files that still exist in the site but that 
aren’t linked to by any other files in the site) (Figure 1). You can search an open file, a portion of a local site, or an 
entire local site.

Checking links in a local site

Figure 1 Link Checker panel

Dreamweaver verifies links only to documents within the site; Dreamweaver compiles a list of external links in the 
selected document or documents but does not verify them.

You can also identify and delete files that are no longer used by other files in your site.

To check links in a local site:

1. Start Dreamweaver.

2. In the Files panel, select a site from the Current Sites 
pop-up menu.

3. Select Site > Check Links Sitewide.

The Broken Links report appears in the Link Checker 
panel (Figure 1).

4. In the Link Checker panel, select External Links or 
Orphaned Files from the Show pop-up menu to view 
another report. 

A list of files that fit the report type you selected appears 
in the Link Checker panel.

Note: If you select Orphaned Files as your report type, 
you can delete orphaned files from the Link Checker 
panel by selecting a file in the list and pressing the Delete 
key. 

5. Fix any broken links and check the links again.

Note: To clear the current Link Checker results, select 
Clear Results from the Link Checker Options menu.

Figure 2 Files panel

Link Checker Options menu

Current 
Sites menu
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How to create and edit a CSS rule
You can create and edit a CSS rule in two locations: the Properties panel and the CSS Styles panel. When you apply 
CSS styles to text by using the Properties panel or menu commands, CSS rules are embedded in the head of the 
current document. You can also use the CSS Styles panel to create and edit CSS rules and properties. 

In this guide, you review CSS rules, create and apply a class-style CSS rule by using the Properties panel, and modify 
an HTML tag-style rule by using the CSS Styles panel.

About CSS rules
A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):

h1 { 

font-family: Georgia, "Times New Roman", Times, serif;

font-size: 18px;

text-transform: uppercase;

color: #090; 

}

An individual declaration consists of two parts: the property (such as font family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, uppercase, and bright green (hex value #090). 

The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 1). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.

Figure 1 Updating a CSS rule in one place updates all elements
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There are three main types of CSS:

Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 

HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.

ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 

CSS rules can reside in the following locations:

Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section of 
an HTML document.

External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website with a link or an @import rule in the head section of a 
document. 

Creating a new CSS rule from the Properties panel
In the CSS Properties panel, you can access Targeted Rules and create new ones (Figure 2). A Targeted Rule is a rule 
you are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the 
text’s format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to 
create new CSS rules and new in-line styles or apply existing classes to selected text. 

Figure 2 Properties panel, CSS mode

How you edit your CSS depends on selection level. To access rules that apply to a current selection only, you can use 
the Targeted Rule pop-up menu in the CSS Properties panel. To access all CSS rules for a page, you can use the CSS 
Styles panel. The CSS Styles panel will be reviewed in the next guide.

In this section, you use the Properties panel to create a simple CSS class-style rule to format a block of text.
How to create and edit a CSS rule © 2012 Adobe Systems Incorporated
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To create a new CSS rule in the Properties panel:

1. Start Dreamweaver.

2. Select File > New to create a new document.

The New Document dialog box appears (Figure 3).

3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.

4. In the Layout column, select None. 

5. Click the Create button.

The new HTML page opens.

6. In the Document toolbar, click the Show Code And 
Design Views (Split) button (Figure 4).

Being able to view the code that Dreamweaver generates 
for creating styles will be useful to help you understand 
and write your own CSS syntax later on.

7. Type some text or paste text copied in another application 
in the Design view Document window. 

8. Press Enter (Windows) or Return (Mac OS) to create a 
new paragraph and add additional text.

9. Open the Properties panel (Window > Properties), if it 
isn’t already open, and click the CSS button to display 
the CSS Properties panel (Figure 2).

10. Use the Font menu to change the Font to Georgia, Times 
New Roman, Times, Serif (Figure 5).

The New CSS Rule dialog box appears (Figure 6).

Note: It is a good practice to assign a font combination 
instead of a single font. This ensures that most page 
visitors will view page text the same way. A browser uses 
the first font in the combination that is installed in the 
visitor’s system. If none of the fonts in the combination is 
installed, the browser displays the text as specified by the 
visitor’s browser preferences. 

Figure 3 New Document dialog box

Figure 4 Document window view options

Figure 5 Properties panel Font menu

Figure 6 New CSS Rule dialog box

Show Code And Design Views button
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11. In the Selector Type menu, select Class (Can Apply To 
Any HTML Element) (Figure 7).

12. Click in the Selector Name text box and type .myStyle 
(Figure 8).

Note: CSS rules must begin with a period and cannot 
contain spaces or special characters.

13. In the Rule Definition menu, select (This Document 
Only) (Figure 9).

This tells Dreamweaver to create and store the CSS (style 
sheet) in the current document only. The new style will 
not be available for use in other documents.

To create an external CSS document for your entire 
website, you would choose (New Style Sheet File). This 
is discussed in a later guide.

14. Click OK to close the New CSS Rule dialog box.

The new font is applied to the paragraph that contains the 
insertion point. The name of the style appears in the 
Targeted Rule box in the Properties panel (Figure 10).

Note: Because you didn’t select a specific word or 
character, you can continue to define this rule by 
applying additional formatting.

15. In the Properties panel, change the size to 18.

The font size in the paragraph that contains the insertion 
point changes accordingly.

Figure 7 New CSS Rule dialog box, Selector Type 
options

Figure 8 New CSS Rule dialog box, Selector 
Name options

Figure 9  New CSS Rule dialog box, Rule 
Definition options

Figure 10 Targeted Rule in the Properties panel
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16. Click the Color box in the Properties panel and select a 
new color for the text.

The Properties panel shows the targeted rule (.myStyle) 
and its formatting. The targeted rule is applied to the 
paragraph that contains the insertion point (Figure 11).

You can use this CSS rule to format additional text in 
your document.

Observe in Code view that Dreamweaver stores styles 
created with CSS directly in the head section of the 
document (Figure 12).

Figure 11 Formatted paragraph text

Figure 12 Detail of new CSS rule, Code view
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Applying CSS styles
After you create a CSS rule, you can use it to give your entire document or website a consistent appearance. You can 
apply a CSS rule to text by using the Properties panel.

To apply a CSS style:

1. Click anywhere in the paragraph that doesn’t have the 
new CSS style.

2. In the Properties panel, select myStyle (the new CSS rule 
you just created) from the Targeted Rule menu 
(Figure 13).

The new style is applied to the other paragraph 
(Figure 14).

Note: If you edit the CSS style, both paragraphs will be 
updated automatically and consistently. You will learn 
more about creating and modifying CSS in a later guide.

Figure 13 Targeted Rule menu

Figure 14 CSS style applied to both paragraphs

Using the CSS Styles panel
In the CSS Styles panel you can track the CSS rules and properties affecting a currently selected page element 
(Current mode) or all of the rules and properties available to the document (All mode). A button at the top of the 
panel enables you to switch between the two modes. You can also use the CSS Styles panel to modify CSS properties 
in both All and Current modes. 
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The CSS Styles panel in Current mode

In Current mode, the CSS Styles panel displays three panes: a Summary For Selection pane that displays the CSS 
properties for the current selection in the document, a Rules pane that displays the location of selected properties (or 
a cascade of rules for the selected tag, depending on your selection), and a Properties pane where you can edit CSS 
properties for the rule applied to the selection (Figure 15).

Figure 15 CSS Styles panel, Current mode

The CSS Styles panel in All mode

In All mode, the CSS Styles panel displays two panes: an All Rules pane, and a Properties pane. The All Rules pane 
displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the 
current document. You can use the Properties pane to edit CSS properties for any rule selected in the All Rules pane 
(Figure 16).

Figure 16 CSS Styles panel, All mode

New CSS Rule Edit RuleAttach Style Sheet
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To add a CSS rule by using the CSS Styles panel:

1. Start Dreamweaver.

2. Create a new HTML document.

3. Save and name the Dreamweaver document.

4. Type some text in the document. Make sure no 
formatting is applied to the text (Figure 17).

5. Make sure the CSS Styles panel is open.

If it is not, select Window > CSS Styles.

6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel (Figure 15).

The New CSS Rule dialog box appears (Figure 18).

7. In the Selector Type pop-up menu, select Class. 

This option creates a new Class rule.

8. In the Selector Name text box, type a name for the style 
such as .warning.

Note: Class rule names must begin with a period and 
cannot contain spaces or special characters. If you forget 
to type the period, Dreamweaver adds this automatically.

9. In the Rule Definition pop-up menu, select (This 
Document Only) or (New Style Sheet File). 

The option (This Document Only) defines the style as 
part of the document’s internal style sheet. The option 
(New Style Sheet File) defines the style as part of an 
external style sheet.

Note: If you choose to create an external style sheet by 
selecting (New Style Sheet File), you are prompted to 
select a location for the new style sheet (.css) document.

10. Click OK.

The CSS Rule Definition dialog box appears (Figure 19).

11. Select options for Type, such as the following: 

• Select Arial, Helvetica, Sans-serif in the Font-
Family pop-up menu

• Select 12 from the Font-Size pop-up menu, and 
select px (pixels) for the measurement unit.

• Type #CC0033 in the Color text box, or select a 
color in the color picker.

Figure 17 Text with no formatting applied

Figure 18 New CSS Rule dialog box

Figure 19 CSS Rule Definition dialog box, Type 
options 
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12. To change the formatting of text blocks, select Block in 
the Category pane.

The Block category of the CSS Rule Definition dialog 
box opens (Figure 20).

13. In the Letter-Spacing text box, you can make changes 
such as typing 3 and selecting pixels for the measurement 
unit.

This setting adds space between letters. 

14. In the Text-Indent box, you can make changes such as 
typing 5 and selecting pixels for the measurement unit.

15. Click OK.

The CSS Rule Definition dialog box closes.

16. Select the document text.

17. Make sure the Properties panel is open and the HTML 
option is selected.

The Properties panel is docked at the bottom of the 
screen. If it is not open, select Window > Properties.

18. Select warning, or the name of your style, from the Class 
pop-up menu (Figure 21).

19. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once.

Observe that the format of the text has changed 
(Figure 22).

20. Make sure the CSS Styles panel is open.

If it is not, select Window > CSS Styles.

21. Make sure All is selected in the CSS Styles panel. If no 
styles are listed under <style> in the All Rules pane, click 
the plus (+) symbol (Windows) or the disclosure triangle 
(Mac OS).

Observe that the newly created CSS rule now appears 
under <style> in the All Rules pane, indicating the new 
rule is part of a CSS style sheet. Also observe that if you 
select the style name in the All Rules pane, properties for 
the style appear in the Properties pane.

Figure 20 CSS Rule Definition dialog box, Block 
options 

Figure 21 Text Properties panel

Figure 22 Formatting applied to text
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Edit styles

After you create styles, you can still make changes to them by using the Edit Rule button.

To edit styles:

1. To view a style sheet’s rules, click the plus symbol 
(Windows) or disclosure triangle (Mac OS) beside 
<style> in the All Rules pane of the CSS Styles panel.

Dreamweaver displays the style sheet’s rules 
(Figure 23). 

2. Select the rule or style you want to edit.

3. At the bottom of the CSS Styles panel, click the Edit Rule 
button.

The CSS Rule Definition dialog box for the selected style 
appears (Figure 24).

4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK.

The changes take effect immediately. 

If you are editing an external style sheet, the same 
changes are applied to any other documents attached to 
this style sheet.

Figure 23 CSS Styles panel

Figure 24 CSS Rule Definition dialog box

Edit Rule 
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How to work with external Cascading Style Sheets
Many web professionals find that using an external style sheet--a style sheet that exists in its own file--offers a 
number of advantages over including styles in the header of an HTML file. These advantages include:

• Flexibility: With CSS stored in one file, you can easily change the appearance of all documents that refer to 
the external style sheet.

• Consistency: All documents sharing the same style sheet will have a similar appearance.

Using an external style sheet separates form from content. Separating form from content is a widely-adopted principle 
in web design which allows, among other benefits, for content to be shared in a range of contexts. 

Exporting CSS rules to an external style sheet
You can convert an internal CSS style sheet to an external one by exporting it, removing the internal CSS style sheet, 
and attaching the exported CSS style sheet to one or more web pages. 

To export a style sheet:

1. Start Dreamweaver and open the CSS Styles Panel 
(Window > CSS Styles) (Figure 1).

2. Confirm that All is selected in the CSS Styles panel.

3. Select the CSS rule you want to move to an external style 
sheet.

Note: To move more than one rule at a time, you can 
Shift-click to select multiple rules that are next to each 
other. To select multiple rules that aren’t next to each 
other, you can Control-click (Windows) or Command-
click (Mac OS) the names of the rules.

4. Right-click (Windows) or Control-click (Mac OS) the 
selected rule(s) and select Move CSS Rules in the context 
menu.

The Move To External Style Sheet dialog box opens 
(Figure 2).

Figure 1 CSS Styles panel

Figure 2 Move To External Style Sheet dialog box
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5. Select A New Style Sheet and then click OK.

The Save Style Sheet File As dialog box opens 
(Figure 3).

6. Browse to a location for the CSS file, enter a name for the 
file, and click Save.

Note: It is good practice to place CSS files in their own 
folder and good practice to name that folder css.

Dreamweaver exports the CSS file.

Figure 3 Save Style Sheet File As dialog box

To delete an internal style sheet:

1. In the CSS Styles panel under All, select <style>.

2. Click the Delete Embedded Stylesheet button (Figure 4).

Dreamweaver removes the internal style sheet. If the 
internal style sheet contains any styles still being used on 
the page, the affected text reverts to its default 
formatting, or it takes on the formatting defined in the 
external style sheet.

Figure 4 CSS Styles panel

Delete Embedded Style Sheet button
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Attaching an external style sheet
Once you create an external style sheet and attach it to multiple documents, you can instantly change any style in all 
your documents by making changes to the external style sheet.

Note: Once you start using an external style sheet, it is best to make all text formatting changes through that style 
sheet. If you make formatting changes through the Properties panel, Dreamweaver will automatically create a new 
internal style sheet.

To attach an external style sheet:

1. Open a document in Dreamweaver.

2. Confirm that the CSS Styles panel is open.

If it is not, select Window > CSS Styles.

3. Click the Attach Style Sheet button (Figure 5).

The Attach External Style Sheet dialog box opens 
(Figure 6).

4. Click Browse, navigate to your saved style sheet, select 
it, and click OK.

5. In the Attach External Style Sheet dialog box, click OK.

Dreamweaver attaches the style sheet to your document 
(Figure 7).

The style sheet’s rules are now available in the Properties 
panel. You may need to expand the style sheet to see its 
rules.

You can attach the same style sheet to multiple 
documents. When you make changes to the style sheet, 
those changes will appear in all documents the style sheet 
is attached to.

Figure 5 CSS Styles panel

Figure 6 Attach External Style Sheet dialog box

Figure 7 Attached style sheet

Attach Style Sheet button
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Creating external style sheets
You can also create external style sheets directly from the New Document dialog box. 

To edit create an external Style Sheet:

1. Select File > New to create a new document.

The New Document dialog box opens (Figure 8).

2. In the Blank Page category of the New Document dialog 
box, select CSS for Page Type.

3. Click Create. 

The untitled CSS page opens in Dreamweaver in Code 
View (Figure 9).

4. Save the document to the site root folder.

5. Return to the HTML document in which you previously 
applied a style by using the CSS Styles panel.

6. In Code View, drag to select the two or more styles you 
previously created. Be sure to include the selectors and 
everything that falls between, including the braces 
(Figure 10).

7. Select Edit > Cut.

8. Click the newly-created CSS document in the Document 
window.

9. Place the cursor on line 4, beneath the CSS comment.

10. Select Edit > Paste.

The copied CSS styles are pasted from the Clipboard into 
the CSS document.

11. Select File > Save.

12. Return to the HTML document in the document window.

Notice in the Design View that all formating for the text 
is gone. In the next steps, you re-apply the CSS styles by 
linking to the external CSS document you just created.

13. In the CSS Styles panel, click the Attach Style Sheet 
button in the lower-right corner of the pane (Figure 5).

The Attach External Style Sheet dialog box opens 
(Figure 11).

14. Click the Browse button and browse to the external CSS 
style sheet that you saved to your site root folder, and 
confirm that the Add As: Link option is selected.

15. Click OK.

A link to the CSS document is added to Head section of 
the  file, and the CSS rules are applied to the text in the 
HTML document.

16. Save the file.

Figure 8 New Document dialog box

Figure 9 New, blank CSS document

Figure 10 Selecting CSS styles

Figure 11 Attach External Style Sheet dialog box
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How to create forms
You can use forms to interact with or gather information from site visitors. With forms, visitors can provide feedback, 
sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver CS6, you can create a 
variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, and clickable 
images (such as a Submit button).

The Forms category in the Insert panel (Figure 1) contains buttons for creating forms and inserting form elements.

Figure 1 Forms category in the Insert panel

The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form processing, 
contact your site administrator. This guide helps you make the user interface of a form.

Setting up a form
You set up a form by inserting it and configuring options through the Properties panel.

To set up a form:

1. Open a page in Dreamweaver.

2. Place the insertion point on the page where you want to 
insert a form or draw a new div for more precise 
positioning of the form on your page. 

Note: To draw a new div, click Draw AP Div in the 
Layout category in the Insert panel, and then drag to draw 
the div. Be sure to make the div large enough to contain 
the entire form you plan to create.
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3. Select the Forms category in the Insert panel (Figure 1), 
and click Form. 

A blank form appears, with a red dotted outline 
(Figure 2). You place all form elements inside this 
outline. If you placed the form inside a div, you may need 
to click outside the div to see the entire form outline.

Form options appear in the Properties panel.

4. From the Method pop-up menu in the Properties panel 
(Figure 3), select either GET or POST.

• GET appends the form contents to the URL specified 
in the Action text box. Use GET if the form data is 
short and the results of the form will lead to a page 
that you want the visitor to be able to bookmark.

• POST sends the form contents directly to the server 
in a manner that is not visible to the visitor. Use 
POST if the form data might be long (if, for instance, 
the form includes a text field that the visitor can use 
to type an unlimited amount of text). 

5. In the Action text box, type the URL or CGI script that 
will process the form.

Note: Get this information from your site administrator.

Figure 2 New, empty form

Figure 3 Forms Properties panel

Adding form elements
Using the Forms category in the Insert panel, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose.

Using form fields

Form fields enable site visitors to enter text into a form. Form fields include the following:

• Text fields, in which a visitor types a response

• File fields, in which a visitor types the path of a file to upload to your server

Adding text fields

Text fields provide a space in which visitors can enter text.
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To add a text field:

1. Click the Text Field button in the Insert panel.

The Input Tag Accessibility Attributes dialog box opens 
(Figure 4).

2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the text field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).

The ID is used by HTML and/or Javascript code to 
distinguish this input tag from others, but it isn’t visible 
to site visitors.

3. Enter a label for the text field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 

The label will be displayed next to the text field, 
indicating to the visitor what to put in the field.

4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

5. In the Add Form Tag dialog box, click Yes.

The text field appears in the form (Figure 5).

6. Click in the text field (not the label) to select it.

7. In the form Properties panel (Figure 6), select one of the 
three types of text fields:

• Single Line text for short answers

• Multi Line text for long answers such as the visitor’s 
description of a problem with a purchased item

• Password text for passwords (in which asterisks 
appear in place of typed characters)

Note: You can also create a multiple-line text field by 
clicking the Text Area button in the Insert panel.

Figure 4 Input Tag Accessibility Attributes dialog 
box

Figure 5 Example of text field in the form

Figure 6 Form Text Field Properties panel

Adding a file field

A file field enables site visitors to select a file on their computers (such as a word-processing document or graphics 
file) and upload it to your server. A file field looks like other single-line text fields, except it also provides a Browse 
button. The visitor either types the path to the file they want to upload or uses the Browse button to locate and select 
the file.
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To add a file field:

1. Click the File Field button in the Insert panel.

The Input Tag Accessibility Attributes dialog box opens

2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the file field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).

3. Enter a label for the file field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 

4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

The file field appears in your document (Figure 7).

5. Click in the file field (not the label) to select it. In the 
Properties panel, in the Char Width text box, specify the 
maximum number of characters visitors will see in the 
field (Figure 8).

6. In the Max Char text box, specify the maximum number 
of characters the field will hold.

Note: Contact your site administrator to confirm that 
anonymous file uploads are allowed before using the file 
field.            

Figure 7 File field example

Figure 8 Form File Field Properties panel

Using checkboxes and radio buttons
Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option on or 
off, or they can select one or more options from a group of options. With radio buttons, visitors can select only one 
option from a group of options.

To add a checkbox:

1. Click the Checkbox button in the Insert panel.

The Input Tag Accessibility Attributes dialog box opens

2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the checkbox in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).

3. Enter a label for the checkbox in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

The checkbox button appears in your document 
(Figure 9).

5. Click the checkbox (not the label) to select it.

6. In the Checked Value text box in the Properties panel 
(Figure 10), enter a value for the checkbox.

This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes.

7. For Initial State, select Checked if you want an option to 
appear selected when the form first loads in the visitor’s 
browser. Otherwise, select Unchecked.

Figure 9 Example of checkbox

Figure 10 Form Checkbox Properties panel

To add a group of radio buttons:

1. Click the Radio Group button in the Insert panel to insert 
a group.

The Radio Group dialog box opens (Figure 11).

2. Enter a name in the Name text box.

3. Click the plus (+) button to add a radio button to the 
group.

4. Enter a label and (if you want) a checked value for each 
button.

5. Select an item in the radio button list, and click the up or 
down arrows to reorder the buttons.

6. Select Line Breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table. 

7. Click OK.

The group of radio buttons is added to the form 
(Figure 12).

8. Click a radio button (not its label) to select it.

Figure 11 Radio Group dialog box

Figure 12 Example of Radio Group
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9. In the Properties panel, click Checked or Unchecked to 
indicate if this option is selected by default (Figure 13).

Figure 13 Form Radio Button Properties panel

Using list menus and drop-down menus (List/Menu)
Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item from 
a pop-up menu.

To add a list menu:

1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).

The Input Tag Accessibility Attributes dialog box opens.

2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the list menu in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore ( _ ).

3. Enter a label for the list menu in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 

4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

A list/menu field appears in your document (Figure 14).

5. Click the list/menu field (not its label) to select it.

6. In the Properties panel, for Type, select List (Figure 15).

Figure 14 Example of list/menu field

Figure 15 Form List Menu Properties panel
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7. In the Height text box, enter the number of items the list 
will display.

If this number is less than the total number of items in the 
list, a scroll bar will be displayed.

8. If you want to allow visitors to select more than one item 
in the list, select Allow Multiple for Selections.

9. Click the List Values button to add the list items.

The List Values dialog box opens (Figure 16).

10. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list.

11. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.

If you enter no value, then the form sends the label as the 
value for that item.

12. Press Enter (Windows) or Return (Mac OS).

13. To add another item to the list, click the plus (+) button.

14. When you finish, click OK to close the List Values dialog 
box.

Figure 16 List Values dialog box

Figure 17 Form List Menu Properties panel

15. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Properties panel (Figure 18).

The Initially selected item appears in the form 
(Figure 18).

Figure 18 Form list with three items in the list

To add a drop-down menu:

1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).

The Input Tag Accessibility Attributes dialog box opens.

2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the pop-up menu in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).

3. Enter a label for the pop-up menu in the Label text box. 
You can leave the other properties in the dialog box at 
their default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

A list/menu field appears in your document (Figure 19).

5. Click the list/menu field (not its label) to select it. 

6. In the Properties panel, for Type, select Menu.

7. Click the List Values button to add the menu items.

The List Values dialog box opens (Figure 20).

8. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu.

9. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.

10. Press Enter (Windows) or Return (Mac OS).

11. To add another item to the menu, click the plus (+) 
button.

12. When you finish, click OK to close the List Values dialog 
box.

13. To have one of the items in the menu selected by default, 
select that item in the Initially Selected text box in the 
Properties panel. 

Note: To see the menu items in operation,  preview this 
page in a browser (Figure 21).

Figure 19 A list/menu field

Figure 20 List Values dialog box

Figure 21 Preview in a browser

Using form buttons
Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser's default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice.

To add a standard text button:

1. Click the Button button in the Insert panel.

The Input Tag Accessibility Attributes dialog box opens.

2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).

Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.
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3. Don’t enter a label for the button. Click OK to close the 
Input Tag Accessibility Attributes dialog box.

Note:  A label would appear next to the button, rather 
than on it, so you don’t want a label for a button form 
element. The text on the button itself is set by the button’s 
value attribute, which you will set in the next step.

A text button appears in the document (Figure 22).

Note: In this example, a Submit button is placed below 
an existing file field.

4. Click the button to select it.

5. In the Properties panel’s Value text box, enter the text you 
want to appear on the button (Figure 23).

Note: It’s a good idea to set the value to whatever the 
button does. “Submit” is a good choice, but you might 
also consider brief phrases in the forms of commands (for 
example, “Send Message” or “Update Profile” or 
“Register”).

6. Select the type of Action (usually this is Submit Form).

Figure 22 Example of text button

Figure 23 Form Button Properties panel

Adding a graphical submit button

You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel.

To add a graphical submit button:

1. Click the Image Field button in the Insert panel.

The Select Image Source dialog box appears (Figure 24).

2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Open (Mac OS).

The Input Tag Accessibility Attributes dialog box opens.

3. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).

Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.

Figure 24 Select Image Source dialog box
© 2012 Adobe Systems Incorporated How to create forms 9
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4. Don’t enter a label for the button. Click the OK button to 
close the Input Tag Accessibility Attributes dialog box.

The graphical submit button appears in your document 
(Figure 25).

5. Click the button to select it.

6. In the Alt text box, type alternate text you want to appear 
in place of the image for text-only browsers (Figure 26). 
This should match any text displayed on the button.

Note: You can also click the folder icon beside the Src 
text box to select a new image for the button.

Figure 25 Example of graphical submit button 

Figure 26 Form Image Field Properties panel

Using jump menus for navigation
A jump menu is a pop-up menu with options that link to documents or files. It is a form element that acts as 
navigation. You can create links to documents in your website or other websites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser. Because using this type of menu will cause the browser to 
navigate to another page, don’t mix jump menus with other form elements.

To add a jump menu:

1. Click the Jump Menu button in the Insert panel.

The Insert Jump Menu dialog box opens (Figure 27).

2. Complete the dialog box.

For more information, click the Help button in the dialog 
box.

3. Click OK.

Figure 27 Insert Jump Menu dialog box
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How to publish web files
Once you’ve specified a local site in Dreamweaver, you can specify a remote server for your site as well. The remote 
server (often referred to as the web server) is where you publish your site files so that people can view them online. 
The remote server is simply another computer like your local computer, with a collection of files and folders on it. 
You specify a folder for your site on the remote server, just as you specified a folder for your local site on your local 
computer (Figure 1). Dreamweaver refers to the specified remote folder as your remote site.

Figure 1 Basic screen of the Servers category, Site Setup dialog box

When you set up a remote folder, you select a connection method for Dreamweaver to upload files to your web server 
and download files from your web server. The most typical connection method is FTP, but Dreamweaver also 
supports local/network, FTPS, SFTP, WebDav, and RDS connection methods. If you don’t know which connection 
method to use, ask your teacher or your school server administrator.

Connecting to a remote site
Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Adobe Dreamweaver CS6. 

To connect to a remote site by FTP:

1. Select Site > Manage Sites.

The Manage Sites dialog box opens (Figure 2).

2. Double-click the name of the site you want to connect 
remotely.

The Site Setup dialog box opens.

Figure 2 Manage Sites dialog box
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Project 3 guide Adobe Dreamweaver CS6

2

3. Click the Servers category in the left column.

The Servers category of the Site Setup dialog box opens (Figure 3).

Figure 3 Basic screen of the Servers category, Site Setup dialog box

4. Click the Add New Server button (+).

5. Enter the FTP access information as directed by your teacher (Figure 1).

6. Click Test to test the connection.

Dreamweaver confirms the connection.

7. Click Save.

The new server appears in the list of servers in the Site Setup dialog box.

8. Click Save to close the Site Setup dialog box.

9. Click Done to close the Manage Sites dialog box.

Add New Server
How to publish web files © 2012 Adobe Systems Incorporated
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Uploading, Synchronizing, and downloading files
Once you establish an FTP connection, you can use the Get and Put commands to transfer files from the Files panel 
(Figure 4).

Figure 4 Expanded Files panel

When you transfer a document between a local and remote folder using the Files panel, you have the option of 
transferring the document’s dependent files. Dependent files are images, external style sheets, and other files 
referenced in your document that a browser loads when it loads the document.

Note: It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of 
the dependent files are already on the local disk, there’s no need to download them again. This is also true for 
uploading and checking in files: no need if up-to-date copies are already at the remote site.

To upload the entire site for the first time:

1. In the Files panel (Window > Files), select the files to 
upload.

2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 4).

The Files panel expands.

3. Click the Connects To Remote Host button in the Files 
panel toolbar.

Dreamweaver connects to the web server.

4. Select the root folder for your site in the Local (right) 
pane.

5. Click the Put Files button in the Files panel toolbar.

6. You may be presented with a dialog box asking if you 
wish to put the entire site. Click OK.

Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 5).

Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button.

Figure 5 Background File Activity dialog box

Connects/Disconnects Remote Host Get Files Put Files Synchronize Expand/CollapseRefresh
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To upload a revised version of an existing file:

1. Select the file you have revised.

2. Click the Put Files button in the Files panel toolbar.

Dreamweaver uploads the revised file.

Synchronizing the files on your local and remote sites

After you’ve created files in your local and remote sites, you can synchronize the files between the two sites.

Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver 
also confirms which files have been updated after you complete the synchronization.

To synchronize files:

1. (Optional) Select specific files or folders in the Files 
panel or go to the next step to synchronize the entire site.

2. Click the Synchronize button in the Files panel toolbar to 
synchronize files.

The Synchronize Files dialog box opens (Figure 6).

3. Select the direction in which you want to copy the files:

Put Newer Files To Remote uploads all the local files that 
don’t exist on the remote server or have changed since 
the last upload.

Get Newer Files From Remote downloads all the remote 
files that don’t exist locally or have changed since the last 
download.

Get And Put Newer Files places the most recent versions 
of all the files on both the local and the remote sites.

4. Choose whether to delete the files on the destination site 
that don’t have counterparts on the origin site. (This is 
not available if you select Get and Put from the Direction 
menu.)

If you select Put Newer Files To Remote and you select 
the Delete option, then any files in your remote site for 
which there are no corresponding local files are deleted. 
If you select Get Newer Files From Remote, then any 
files in your local site for which there are no 
corresponding remote files are deleted.

Figure 6 Synchronize Files dialog box 
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5. Click Preview.

Dreamweaver analyzes the local and remote folders, and 
then the Synchronize dialog box opens (Figure 7).

Note: Before you can synchronize the files, you must 
preview the actions Dreamweaver performs to 
accomplish this task. 

If the newest version of each chosen file is already in 
both locations and nothing needs to be deleted, an alert 
appears informing you that no synchronization is 
necessary. Otherwise, the Synchronize dialog box 
appears to let you change the actions (put, get, delete, and 
ignore) for those files before executing the 
synchronization.

6. Verify the action that will be performed for each file.

7. Click OK to synchronize the files.

Figure 7 Synchronize dialog box 

Downloading files to work on them

Once your website has been published, you may want to download a file so you can revise it. You do so through the 
Remote Site pane, on the left side of the expanded Files panel.

To download a file:

1. Click the Refresh button in the Files panel toolbar 
(Figure 4) to make sure the files in the Remote Site pane 
are up-to-date.

2. Select a file to download.

3. Click the Get Files button.

If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 8). 

Note: If you do not click Yes within 30 seconds, the 
Dependent Files dialog box automatically closes and 
dependent files are not downloaded.

4. Click Yes.

Dreamweaver copies the file and its dependent files to 
your local folder. The downloaded files appear in the 
right pane of the expanded Files panel.

5. Click the Disconnects From Remote Host button, and 
then collapse the Files panel.

Figure 8 Dependent Files dialog box 
© 2012 Adobe Systems Incorporated How to publish web files 5



Adobe Dreamweaver CS6 Project 3 guide
How to use templates
You can use an Adobe Dreamweaver CS6 template to create multiple pages with the same layout. In a template, you 
control which page elements should remain constant in documents based on that template and which elements can be 
changed from page to page. Templates are helpful for building a website in which most pages have the same header, 
navigation system, and other elements. Using templates helps you save time as well as create and maintain a 
consistent look when more than one person is developing a site.

Creating a template
You create templates from existing pages, setting editable regions on these pages that will hold content on each page 
created from the template.

To create a template:

1. Start Dreamweaver.

2. Build a page that contains elements designed to appear 
on all content pages such as common graphics, a 
navigation bar, and common layout structures such as div 
tags (Figure 1).

Note: You may want to create navigation elements in 
Adobe Fireworks CS6 and export them as HTML 
documents.

3. Select File > Save As Template.

4. In the Save As Template dialog box (Figure 2), give the 
template a name. You can also enter a brief description of 
the template. Then click Save. If Dreamweaver asks if 
you want to update links, click Yes.

Dreamweaver creates a Templates folder in your site root 
folder and saves your template in that folder. Template 
files have a .dwt file extension.

Figure 1 Common elements on a web page

Figure 2 Save As Template dialog box
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To create an editable region:

1. In the Layout category of the Insert panel, click Draw AP 
Div, and then drag on the page to create a new div to 
represent the editable region in the template.

Note: You also click to indicate where to place the 
editable region, but using a div gives you more control 
over page layout. 

2. With the div still selected, do one of the following to 
create an editable region:

• Select Insert > Template Objects > Editable Region.

• Right-click (Windows) or Control-click (Mac OS) 
the region and select Templates > New Editable 
Region from the context menu.

• In the Common category of the Insert panel, click the 
Templates button (Figure 3), and select Editable 
Region from the pop-up menu.

The New Editable Region dialog box opens (Figure 4).

3. In the dialog box, enter a unique name for the region, and 
click OK.

The editable region is within the selected div, and is 
enclosed in a light blue rectangle on the template 
(Figure 5).

Note: You cannot use the same name for more than one 
editable region in a particular template. Use only letters 
and numbers in the name.

4. Save and close the template.

Figure 3 Templates button on the Insert panel

Figure 4 New Editable Region dialog box

Figure 5 New editable region inside the div
How to use templates © 2012 Adobe Systems Incorporated



Adobe Dreamweaver CS6 Project 3 guide
To create a document based on a template:

Once you create a template, you can use it to create new 
documents.

1. Select File > New.

2. In the New Document dialog box, select the Page From 
Template category.

The dialog box displays your sites and all of the 
templates for the selected site (Figure 6).

3. In the Sites list, select the site that contains the template 
you want to use.

4. Select the template you want to use.

5. Make sure the Update Page When Template Changes 
option is selected.

With this option selected, Dreamweaver can update all 
template-based pages if you change the template later.

6. Click Create to create a new template-based page.

The document opens in the Document window.

7. Click in one of the editable regions, and add text.

8. Move the pointer over a page area that is not editable, and 
observe that you cannot make changes.

9. Save the page.

Figure 6 Page From Template category in the New 
Document dialog box

Editing a template
You can edit a template at any time, even if you have created pages based on the template.

To edit a template:

1. Select Window > Assets.

The Assets panel opens.

2. Click the Templates button on the left side of the panel 
(Figure 7).

A list of the templates for your site appears in the lower 
pane. The upper pane displays a preview of the selected 
template. (You may need to scroll the preview pane to see 
this.)

3. Select the template you wish to edit and do one of the 
following:

• Double-click the name of the template.

• Click the Edit button at the bottom of the panel 
(Figure 7).

4. Edit the template in the Document window, changing 
non-editable elements or creating editable regions in the 
template as desired.

Figure 7 Assets panel

Templates Edit Delete
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5. Save the edited template by choosing File > Save.

The Update Template Files dialog box opens, with a list 
of the documents based on your template (Figure 8).

6. Click Update to update the documents based on the 
changes you made in your template.

The Update Pages dialog box displays a summary of the 
updates performed (Figure 9). You may need to select 
Show log to view the Status information.

7. Click Close.

Figure 8 Update Template Files dialog box

Figure 9 Update Pages dialog box

Deleting a template

To delete a template:

1. Select the template in the Assets panel.

2. Click the Delete button (trash can icon) at the bottom of 
the panel and confirm that you want to delete the 
template (Figure 7).

The template file is deleted from your site.

Documents that were based on a template you have 
deleted retain the structure and editable regions the 
template file had before you deleted it. To turn such a 
document into a normal HTML file without editable or 
locked regions, you must detach it from the template.

Detaching from a template
To remove the template structure and constraints from a document based on a template, you can detach the document 
from the template. When a document is detached from its template, you can edit any element, including the regions 
that were previously locked.

To detach a file from a template

1. To detach a document from a template, open the 
document.

2. Select Modify > Templates > Detach From Template.
How to use templates © 2012 Adobe Systems Incorporated
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How to lay out a web page with CSS
A CSS page layout uses the Cascading Style Sheets format, rather than traditional HTML tables or frames, to 
organize the content on a web page. The basic building block of the CSS layout is the div tag—an HTML tag that in 
most cases acts as a container for text, images, and other page elements. When you create a CSS layout, you place div 
tags on the page, add content to them, and position them in various places. Unlike table cells, which are restricted to 
existing somewhere within the rows and columns of a table, div tags can appear anywhere on a web page. You can 
position div tags absolutely (by specifying x and y coordinates), or relatively (by specifying their distance from other 
page elements). You can also position div tags by specifying floats, paddings, and margins—the preferred method by 
today’s web standards.

Creating CSS layouts from scratch can be difficult because there are so many ways to do it. You can create a simple 
two-column CSS layout by setting floats, margins, paddings, and other CSS properties in a nearly infinite number of 
combinations. Additionally, the problem of cross-browser rendering causes certain CSS layouts to display properly in 
some browsers and improperly in others. Dreamweaver makes it easy for you to build pages with CSS layouts by 
providing 16 pre-designed layouts that work across different browsers.

Using the pre-designed CSS layouts is the easiest way to create a page with a CSS layout, but you can also create CSS 
layouts by using absolutely-positioned elements (AP elements). An AP element in Dreamweaver is an HTML page 
element—specifically, a div tag or any other tag—that has an absolute position assigned to it (Figure 1). The 
limitation of Dreamweaver AP elements, however, is that since they are absolutely positioned, their positions never 
adjust on the page in relation to the size of the browser window.

Once you become more experienced you will be able to create page layouts by inserting div tags manually and 
applying CSS positioning styles to them.

Figure 1 AP elements in the Dreamweaver Document window

Inserting an AP div tag
Start this activity by creating a new, blank page and inserting an AP div tag. AP elements can contain text, images, or 
any other content that you can place in the body of an HTML document.
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To insert an AP div tag:

1. Start Dreamweaver.

2. Select File > New.

The New Document dialog box opens (Figure 2).

3. With the Blank Page category selected, click HTML 
under Page Type and <none> under Layout.

4. Click Create.

A new untitled HTML document opens.

5. Save the new page.

The new file is added to the Files panel.

6. Select the Layout category in the Insert panel and 
confirm the Standard mode button is selected (Figure 3)

7. Click the Draw AP Div button.

The mouse pointer chanages to a cross when you move it 
over the Document window.

8. To create the div that will define an area of your page, 
drag a rectangle in the Dreamweaver document. 

9. Click the border of the div to select it.

Handles appear along the border (Figure 4) and the div 
properties appear in the Properties panel. 

Figure 2 New Document dialog box

Figure 3 Insert panel, Layout category

Figure 4 Div inserted and selected
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10. Make sure the Properties panel is open (Figure 5). 

It is docked at the bottom of the screen. If the Properties 
panel is not open, select Window > Properties.

11. Click in the CCS-P Element ID box and enter a name for 
the div. 

Choose a unique name that will help you remember the 
div’s contents, such as header or navigation.

Note: “CSS-P” is a commonly accepted abbreviation for 
“CSS Positioning”.

12. Click the Bg Color box and select a color in the color 
picker. 

The div changes to the selected color. 

13. Click once outside the new div to deselect it. 

A thin black line appears around the div. This line does 
not appear in a browser. If you do not see the line, select 
View > Visual Aids > CSS Layout Outlines.

14. Continue adding divs for all the sections on your page. 
You can place divs directly alongside one another 
(Figure 6).

15. Open the AP Elements panel (Window > AP Elements).

You’ll see that Dreamweaver has added the new divs to 
the list of AP Elements (Figure 7). 

Note: Select Prevent Overlaps to constrain the positions 
of AP elements when they are created, moved, and 
resized, so that they don’t overlap.

16. Save your page.

Figure 5 Properties panel

Figure 6 Multiple divs on page

Figure 7 AP Elements panel

Resizing divs
You can resize an individual div or simultaneously resize multiple divs to make them the same width and height.

Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.

CSS-P Element ID box
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To resize a div:

1. Select a div by clicking its border or by clicking the div’s 
name in the AP Elements panel.

2. Do one of the following to resize the div:

• To resize by dragging, drag any of the div’s resize 
handles (Figure 8).

• To resize one pixel at a time, hold down Control 
(Windows) or Option (Mac OS) while pressing an 
arrow key.

Note: The arrow keys move the right and bottom 
borders of the div; you can’t resize the top and left 
borders with this technique.

• In the Properties panel, type values for width (W) 
and height (H).

Figure 8 Resize by dragging

Moving divs
You can move divs in Design view in much the same way you move objects in most basic graphics applications.

Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.

To move a div:

1. Select one or more divs.

2. Do one of the following:

• To move by dragging, drag the div’s selection handle 
(Figure 9).

• To move one pixel at a time, use the arrow keys.

Figure 9 Moving a div

Adding content to divs
You can add images, text, and other content (such as Flash movies) to your divs just as you would elsewhere in a web 
page.

To add content to a div:

1. To insert an image in a div, click in the div and select 
Insert > Image.

Note: Make sure the div is sized large enough to hold the 
image or other content. If the div is sized smaller than the 
image, the div may not display correctly in all browsers.

Div resize handle

Selection handle
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2. In the Select Image Source dialog box, locate and select 
an image to insert (such as a page banner). Then click OK 
(Windows) or Open (Mac OS).

The image appears in the div (Figure 10).

3. To format the image in the div, select the image and 
select formatting elements in the Properties panel.

4. To add text to a div, click in the div and type text or paste 
text copied from another document.

Figure 10 Div with image added

Viewing div tags by using Live view
You can use a feature called Inspect mode in Live view to view the code generated by adding the div tags.  

To view div tags using by using Inspect mode in Live view:

1. Click the Live button in the Control panel (Figure 11).

Live view is enabled. This means that the page appears as 
it will in a web browser.

2. Click the Live button again to deactivate Live view.

3. Click the Split button. 

Code and Design view (Split view) view is enabled. This 
lets you see the code alongside the design display. 

4. Click the Live button again to activate Live Code view.

5. In the Design view, click on a div’s selection handle, or 
an image placed within a div and observe that the div tag 
is highlighted in the Code view (Figure 11).

Figure 11 Split Code/Live view

DivHighlighted tag

Live button
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